The Search does not work for resources in "My Cmaps"

Answers to the questions most commonly asked about CmapTools and CmapServer.
Post Reply
cmapadmin
Site Admin
Posts: 657
Joined: Sat Dec 13, 2008 2:22 pm

The Search does not work for resources in "My Cmaps"

Post by cmapadmin » Thu Apr 23, 2009 3:53 pm

The Search function does not work for resources in "My Cmaps". It does not return results, although I know I have resources related to the keyword used in the search. How do I search for resources in "My Cmap"?

The problem is related to the corruption of the "My Cmaps" index file . So, the index needs to be created again. Follow these instructions:
  1. Quit CmapTools.
    • Go to the "CmapTools" profile folder.

      Windows
      • Open a command prompt.
      • In Windows XP, type the command: cd C:\Documents and Settings\<your user name>\Application Data\CmapTools
      • In Windows 7/8/10, type the command: cd C:\Users\<your user name>\AppData\Roaming\CmapTools
      • Type the command: start . (NOTE: there is a "." after start)
      Mac OS X
      • Open the finder
      • Go to the folder: ~/Library/Preferences/CmapTools
      Linux
      • Open a terminal window
      • Type the command: cd .cmaptools (NOTE: there is a "." before cmaptools)
      • Delete the folder titled "local". This is the directory where the index is stored.
        • Restart IHMC CmapTools
        Since the index is not present (the "local" folder under CmapTools has been deleted), CmapTools will recreate it. It should take a couple of minutes, depending on how many resources you have, and you'll notice your disk chattering from all the access.

        Post Reply