CmapTools user interface is too small on Windows

Answers to the questions most commonly asked about CmapTools and CmapServer.
Post Reply
cmapadmin
Site Admin
Posts: 657
Joined: Sat Dec 13, 2008 2:22 pm

CmapTools user interface is too small on Windows

Post by cmapadmin » Fri Feb 23, 2018 12:08 am

If you are using an internal or external monitor with Ultra High Definition (4k UHD) using a higher resolution than 1,920 by 1,080 pixels up to 3,840 by 2,160 pixels, you might experience the following problems in CmapTools:
  • Elements are too small compared to the rest of the desktop.
  • Elements such as icons, toolbars, text, and dialog boxes appear to be fuzzy.
  • Blurry text appears in CmapTools interface.
This scale problem can be fixed from the application or from the operating system. CmapTools is written in Java, and Java fixed the scale problem in the version 9, but CmapTools is not converted to Java 9 yet.

If you lower the resolution of your monitor to at least 1920 x 1080, CmapTools will run normally, but doing this is not using the monitor at its maximum capacity and all applications could look larger.

Latest Windows 10 release seems to solve the problem for some users. You can also change the Java compatibility properties to override display scaling behavior. If you have the problem, try to update windows 10 first and run CmapTools again. If you continue to see the very small CmapTools components, try step 2 below.
  1. Check for Windows 10 updates.

    Windows 10 version 1709 (Fall Creators Update) includes better support for Ultra High Definition monitors. To verify the version number of your Windows type: Winver on the search box on your taskbar. To check Windows 10 updates, see the Windows 10 Update History.
    • Change the Java compatibility properties of Java.

      Open Windows Explorer and navigate to the folder where you installed CmapTools. Typically is on c:\Program Files\IHMC CmapTools. Open the folder c:\Program Files\IHMC CmapTools\jre\bin (1). Do a right-click on the file: javaw.exe (2), select Properties, select the Compatibility tab (3), and then select the Disable display scaling on high DPI settings check box.

      Note

      In Windows 10 Version 1703 and later version of Windows, the text of the Disable display scaling on high DPI settings option is changed to Override high DPI scaling behavior, scaling performed by: Application. (4)
        JavaW-Properties.png

      Post Reply