Mac Sierra, Cmap is frequently non responding

Having problems with IHMC CmapTools? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapTools, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
PietroTerna
Posts: 4
Joined: Wed Feb 08, 2017 5:46 pm

Mac Sierra, Cmap is frequently non responding

Post by PietroTerna » Wed Feb 08, 2017 5:55 pm

I use Camp to teach, an example is at http://terna.to.it/econophysics17/cmap/ ... 16_17.html
My computer is a MacBookPro with 16Gb of Ram, Sierra and Java 8 update 121.
Very frequently Cmap is stuck and Macos signals ii a 'not responding', both with v. 6.01 and 6.02 (worst performances here).
Best, Pietro

cmapadmin
Site Admin
Posts: 622
Joined: Sat Dec 13, 2008 2:22 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by cmapadmin » Wed Feb 08, 2017 10:13 pm

Try adding more memory to Java. The FAQ shows how to do it:

http://cmap.ihmc.us/docs/cmaptools-faqs#1-6

Let us know if it helps. If it doesn't, send us a copy of the log. This entry shows where to find it:

http://cmap.ihmc.us/docs/cmaptools-faqs#1-2

PietroTerna
Posts: 4
Joined: Wed Feb 08, 2017 5:46 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by PietroTerna » Fri Feb 10, 2017 6:37 am

I've added more memory to Java, as suggested.

Now Cmap works perfectly.

Many thanks, Pietro

PietroTerna
Posts: 4
Joined: Wed Feb 08, 2017 5:46 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by PietroTerna » Sat Feb 17, 2018 5:15 pm

Dear all, now with MacOs HighSierra 10.13.3, Cmap 6.03 again is frequently not responding. I've already added more memory to Java, as above.

Best, Pietro

cmapadmin
Site Admin
Posts: 622
Joined: Sat Dec 13, 2008 2:22 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by cmapadmin » Sun Feb 18, 2018 11:45 am

With 16GB it shouldn't be an issue. Do you have a lot of resources (Cmaps, videos, images, etc.) in My Cmaps? It may be indexing them when you launch. But once they are indexed it should be ok. Send us a copy of the log file when you have a session where its not responding.

PietroTerna
Posts: 4
Joined: Wed Feb 08, 2017 5:46 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by PietroTerna » Sun Feb 18, 2018 4:32 pm

Many thanks, two solution following your reply:

1. I wait until the index is built (10-20 seconds) and then the program is very responsive;

2. the map on which I'm working currently contains parts coming (with cut and paste) from other previous maps; guessing that the effect could be a messy structure, I've copied all in one shot and pasted the whole copy in a clean map; this one loads very quickly.

Many thanks, Pietro

cmapadmin
Site Admin
Posts: 622
Joined: Sat Dec 13, 2008 2:22 pm

Re: Mac Sierra, Cmap is frequently non responding

Post by cmapadmin » Sun Feb 18, 2018 4:36 pm

Yes, (2) would be a problem if you use a lot of Styles, as the copy and paste would be copying the styles from each of the maps.

Post Reply