Node Width + Text Selection not working properly

Having problems with IHMC CmapTools? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapTools, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
mrjerz
Posts: 7
Joined: Mon Mar 19, 2018 8:23 am

Node Width + Text Selection not working properly

Post by mrjerz » Mon Mar 19, 2018 9:00 am

Hi,

When I make a node more narrow with the Formatting Object -> Width -> e.g. 100, then selecting the content of the node with the mouse does not work properly. The selection does not reach the end of the text.
Cmap_Text_not_selected.png
How To reproduce the error:
1. Create a Node
2. Fill it with quite a lot of text
3. Make the width of the Node smaller using Formatting Object -> Width -> e.g. 100
4. Try to select with your mouse from top to bottom.

The last characters are not going to be considered by the selection. You can fix the selection using the keyboard with Shift+Arrow Right, but not using the mouse.

I use CmapTools 6.03 on Mac OS High Sierra 10.13.3
I have 8GB of RAM

Is there any way to fix that on my own?
BR

cmapadmin
Site Admin
Posts: 656
Joined: Sat Dec 13, 2008 2:22 pm

Re: Node Width + Text Selection not working properly

Post by cmapadmin » Mon Mar 19, 2018 8:20 pm

Hmmmm.... you are right, this is a bug. Thanks for reporting it.

Cmap Support

Post Reply