CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Having problems with IHMC CmapServer? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapServer, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
User avatar
salustri
Posts: 11
Joined: Wed Dec 30, 2009 6:15 am

CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by salustri » Mon Jun 15, 2015 11:35 am

I just installed a fresh version of CmapServer 6.00.07 on my iMac running Yosemite 10.10.3.
The version of Java in the iMac is "1.6.0_65" (whatever came with OSX).
/sbin/SystemStarter is no longer part of OSX.

I note the installation resulted in a message saying that the installation was complete, but there were "some errors" during the install.
In the installation log file (IHMC_CmapServer_v6.00.07_Install_06_15_2015_13_02_19.log), I find the following:

Install JRE: /Applications/IHMC CmapServer/jre
Status: ERROR
Additional Notes: ERROR - JRE Source does not exist

Install JRE:
Status: SUCCESSFUL

No idea what this means. It looks like JRE was both not-installed and installed.....

Since /sbin/SystemStarter is not available any more, I couldn't figure out how to start the server.

When I try to start it manually, i.e., with:
sudo /Applications/IHMC\ CmapServer/bin/CmapServer.app/Contents/MacOS/CmapServer &
it doesn't start and all I get is this:

---Executable: "/Applications/IHMC CmapServer/jre/bin/java" -Xms512M -Xmx1024M -Djava.awt.headless=true -cp "/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/CMapServer.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/activation.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/checkfile.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/mail.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/symantec.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/slp.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/admintool.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/socks.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/jniregistry.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/admintoolclient.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../bin/cmapserverservices.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/AppleStubs.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/tm-extractors-0.4.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/concurrent.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/winlaf-0.5.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/poi-scratchpad-2.5.1-final-20040804.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/poi-contrib-2.5.1-final-20040804.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/poi-2.5.1-final-20040804.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/multiplayer.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/mediaplayer.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/jmf.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/customizer.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/PDFBox-0.7.3-dev.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/FontBox-0.1.0-dev.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/ldapbp.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/catalina.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/jsp-api.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/servlet-api.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/tomcat-coyote.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/xml-apis.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/xercesImpl.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/googleapi.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-digester.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-collections.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-beanutils.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-beanutils-core.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-beanutils-bean-collections.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/ganymed.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/svnjavahl.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/svnClientAdapter.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/lucene-core-2.4-dev.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/JimiProClasses.zip:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/axiom-impl.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/axiom-api.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/wstx-asl-2.9.3.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/stax-api-1.0.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-logging-1.0.4.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-fileupload-1.2.1.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/bcprov-jdk14-147.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/tomcat-juli.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/tomcat-dbcp.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/jasper.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/jasper-el.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/el-api.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/ecj-3.7.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/catalina-tribes.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/catalina-ha.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/catalina-ant.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../tomcat/lib/annotations-api.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-io-2.2.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/commons-codec-1.6.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/slf4j-log4j12-1.7.6.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/slf4j-api-1.7.6.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/log4j-1.2.17.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes:/Applications/IHMC CmapServer/bin/CmapServer.app/../../classes/java-json.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/Resources/Java/lax.jar:/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/Resources/Java/linking.zip" -Dfile.encoding=UTF-8 -Djava.library.path=.:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:"/Applications/IHMC CmapServer/bin":"/Applications/IHMC CmapServer/jre/lib":"/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/Resources/Java":"/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/MacOS":"/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/Resources" -Xdock:name="CmapServer" -Xdock:icon="/Applications/IHMC CmapServer/bin/CmapServer.app/Contents/Resources/LaunchAnywhere.icns" com.zerog.lax.LAX "/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/app.properties"-------

Please help.
Prof Filippo A. Salustri, PhD, PEng
Ryerson University - Canada
salustri@ryerson.ca
http://deseng.ryerson.ca/~fil

cmapadmin
Site Admin
Posts: 538
Joined: Sat Dec 13, 2008 2:22 pm

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by cmapadmin » Mon Jun 15, 2015 5:31 pm

Is this the complete log file that is generated (in the 'logs' directory)?

User avatar
salustri
Posts: 11
Joined: Wed Dec 30, 2009 6:15 am

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by salustri » Thu Jun 18, 2015 6:07 pm

I've put the log files I can find in my public dropbox for you.
Here's what I can find:
In /Applications/IHMC CmapServer/UninstallerData/Logs I have this file:
https://www.dropbox.com/s/ogxpcl9ybh5qs ... 9.log?dl=0
In /Applications/IHMC CmapServer/logs/ I have
https://www.dropbox.com/s/360djoonc1i1v ... 0.log?dl=0
But on this latter one, I must object, because the file it claims is missing, serverconfig.txt, is there now.
That is, somehow it had disappeared, but I hadn't noticed, so I uninstalled everything and reinstalled from scratch. Thereafter the config file was there.

All other log files are months and months old, back from when it was running fine.

Does this help at all?
Prof Filippo A. Salustri, PhD, PEng
Ryerson University - Canada
salustri@ryerson.ca
http://deseng.ryerson.ca/~fil

User avatar
salustri
Posts: 11
Joined: Wed Dec 30, 2009 6:15 am

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by salustri » Fri Jun 19, 2015 3:09 am

CORRECTION!

I just tried restarting the server manually (using the command noted in my original post above).
The Server did NOT start.
There is a new entry in log server complaining that /Applications/IHMC CmapServer/bin/serverconfig.txt is missing.
But serverconfig.txt exists!

So... could it be a problem with permissions on the serverconfig.txt file?
FYI, you can see my serverconfig.txt file at https://www.dropbox.com/s/h7pywuuty9x3j ... g.txt?dl=0

Also, I've pulled the last 100 lines from the older log file leading up to the last time the server went down.
That log is available at https://www.dropbox.com/s/1frjv3p8p714p ... 3.log?dl=0
I honestly cannot remember what happened that day. It may have been an OSX update, but I really don't know how to check that.
Prof Filippo A. Salustri, PhD, PEng
Ryerson University - Canada
salustri@ryerson.ca
http://deseng.ryerson.ca/~fil

cmapadmin
Site Admin
Posts: 538
Joined: Sat Dec 13, 2008 2:22 pm

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by cmapadmin » Fri Jun 19, 2015 10:45 am

If you are running as root (sudo) then there shouldn't be any permissions problems. The CmapServer does modify the file, but in this case it seems like the file cannot be found at all.

I would recommend backup up the serverconfig.txt file, the serverrootfolder (where the Cmaps are), and try installing the CmapServer again. Could be a special character in the path name during installation? For some reason the /Applications/IHMC CmapServer/ is not being found.

Maybe try installing it in another folder (e.g. with the name "IHMC CmapServer v6") to see if a new installation works, and then copy the old serverconfig.txt and serverrootfolder over.

We can't see anything wrong as it is, we may be missing something.

cmapadmin
Site Admin
Posts: 538
Joined: Sat Dec 13, 2008 2:22 pm

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by cmapadmin » Fri Jun 19, 2015 12:46 pm

We are about to release a new version of the CmapServer, with improvements to the installer. Meanwhile try installing the following 6.03 version (never released to the public):

ftp://ftp.ihmc.us/DownloadCmapTools/Cma ... -13-15.zip

cmapadmin
Site Admin
Posts: 538
Joined: Sat Dec 13, 2008 2:22 pm

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by cmapadmin » Fri Jun 19, 2015 4:33 pm

Try the new version on the ftp site. The public version had a problem with the installer. We'll be posting a new public version soon.

User avatar
salustri
Posts: 11
Joined: Wed Dec 30, 2009 6:15 am

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by salustri » Sun Jun 21, 2015 6:27 pm

Thanks for the info.
I'll try the version from the ftp site some time this week, and will advise ASAP.
Prof Filippo A. Salustri, PhD, PEng
Ryerson University - Canada
salustri@ryerson.ca
http://deseng.ryerson.ca/~fil

cmapadmin
Site Admin
Posts: 538
Joined: Sat Dec 13, 2008 2:22 pm

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by cmapadmin » Sun Jun 21, 2015 6:31 pm

Tomorrow we are uploading v6.04.

We have fixed the problem with the paths and the way the installer was handling them, so this should resolve your problem. Thanks for reporting it.

User avatar
salustri
Posts: 11
Joined: Wed Dec 30, 2009 6:15 am

Re: CmapServer 6.00.07 on OSX 10.10.3 doesn't start

Post by salustri » Wed Jun 24, 2015 9:16 am

6.04 is running!
Thanks very much.
One issue left: since /sbin/SystemStarter is no longer in OSX, can you offer some advice on how to configure launchctl to automatically start CmapServer on boot?
Prof Filippo A. Salustri, PhD, PEng
Ryerson University - Canada
salustri@ryerson.ca
http://deseng.ryerson.ca/~fil

Post Reply