Server disapear from the list of places

Having problems with IHMC CmapServer? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapServer, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
claudef
Posts: 6
Joined: Thu Sep 23, 2010 10:36 am

Server disapear from the list of places

Post by claudef » Fri Apr 01, 2011 8:21 am

Hi,

I host a CMap server (version 5.04) on a Mac server (version 10.6.7). Frequently, the CMap server disapear from the list of places in the client software. I need to reconnect constantly. This situation is problematic when working in collaboration. Do you have a solution for that?

This problem is visible ether on Mac and on Windows clients (5.04.01).

Thanks for your help.

Claude

acanas
Posts: 752
Joined: Tue Mar 17, 2009 5:52 pm

Re: Server disapear from the list of places

Post by acanas » Fri Apr 01, 2011 11:08 am

Can you post a copy of (a) your configuration file for the server? Is the server on the same LAN as the client? Is it registered with the DOP? (check http://dop2.ihmc.us). Please provide more information.

claudef
Posts: 6
Joined: Thu Sep 23, 2010 10:36 am

Re: Server disapear from the list of places

Post by claudef » Fri Apr 01, 2011 12:06 pm

Hi,

Here is the config of the server. No, it is not registered with the DOP. How can i do that?

The problem is present both on the same lan or on remote location.

Thanks for your help.

Claude
Attachments
configCmap.jpg

cmapadmin
Site Admin
Posts: 656
Joined: Sat Dec 13, 2008 2:22 pm

Re: Server disapear from the list of places

Post by cmapadmin » Fri Apr 01, 2011 12:22 pm

OK, this is not the configuration file, but for now it will do. The configuration file is named serverconfig.txt and is located in the 'bin' directory wherever you installed your CmapServer. But this has useful information.

From your CmapSever configuration, the server has an IP address of 192.168.1.6. I can't tell whether this is a fixed address (is this the address in the configuration file) or if it is obtained through DHCP every time the CmapServer is launched.

If this IP address is fixed (not obtained through DHCP) it will work ok for access of the CmapSever from within your LAN, not from outside (e.g. from home). If you want access from outside your organization you'll need to assign it an external IP address.

If your CmapTools client is in the same LAN as the CmapServer, it will find the CmapServer by 'broadcast', that is, it should show up in your Views automatically. However, if the IP address of the CmapServer is obtained through DHCP, it may mean that every time it is restarted (or every time it renews its lease) it will have a different IP address and so the client will find the same CmapServer with another IP address and may get confused, which could explain why the CmapServer 'disappears'.

First, it would help if you can attach a copy of the server config file. You can send me a msg with it as an attachment if you prefer.
Second, if you go to "All Places" in the Views window, is the CmapServer in the list?
Third, have you tried adding the CmapServer manually in the Paces window, providing the IP address 192.168.1.6? What happens when you do?

One last question. Does 'recit.cadre.qc.ca' resolve to 192.168.1.6? That is, does your name server have the 192.168.1.6 address registered?

Hope this help, although it asks more questions than it answers.

claudef
Posts: 6
Joined: Thu Sep 23, 2010 10:36 am

Re: Server disapear from the list of places

Post by claudef » Fri Apr 01, 2011 12:44 pm

Hi,

Thanks for your time.

Yes, the IP adresse 192.168.1.6 is fixe and resolve to recit.cadre.qc.ca so typing http://recit.cadre.qc.ca:8080 direct to the CMap server on the web. This part is always working well. We have a dns server that redirect the public adress to this one so it is working from the outsite of the lan.
Third, have you tried adding the CmapServer manually in the Paces window, providing the IP address 192.168.1.6? What happens when you do?
The server seems to not broarcast himself. I have to add the server in Places each time I use the client. But after several minutes, it remove from the list by itself. Sometime, it stay longer, sometime very short.

Going to All Place does-not list my server each time.

I send you the config file in a private message.

Thanks.

Claude

acanas
Posts: 752
Joined: Tue Mar 17, 2009 5:52 pm

Re: Server disapear from the list of places

Post by acanas » Fri Apr 01, 2011 1:10 pm

The CmapServer is registering with the DOPs with domain address recit.cadre.qc.ca, which resolves to 206.41.89.70.But it knows that its IP address is 192.168.1.6. And so your CmapTools client is getting both addresses, and they are in conflict. The CmapServer cannot have both addresses, only one of them.

You may first try, however, adding the following information to the serverconfig.txt file which seems to be blank from the file you sent me.

server.ip.address= 192.168.1.6
server.hostname=recit.cadre.qc.ca

and see whether it works. The CmapTools uses the hostname first, but the 192.168.1.6 may be a problem here if it creates conflicts, I'd have to check on this but its worth trying.

After this change, wait a few minutes and see whether your server is in the DOP's list (http://dop2.ihmc.us) -- currently it isn't.

If this doesn't work, that is, your clients still get confused, I would take the broadcasting out.

In the slp.conf file, in the same directory you found the serverconfig.txt file, change to:

net.slp.answerBroadcast=false

Not sure this will solve the problem of having 2 IP addresses, give it a try.

claudef
Posts: 6
Joined: Thu Sep 23, 2010 10:36 am

Re: Server disapear from the list of places

Post by claudef » Fri Apr 01, 2011 1:35 pm

Hi,

I made the changes in the config file.

The server is not list in the DOP but it seems to stay in the list of places on my client. I will continue to monitor that for a moment.

Many thanks for your help.

Claude

claudef
Posts: 6
Joined: Thu Sep 23, 2010 10:36 am

Re: Server disapear from the list of places

Post by claudef » Mon Apr 04, 2011 8:48 am

Finally, it does'nt work. My server always disapear from the list of place.

I give a try to that:
In the slp.conf file, in the same directory you found the serverconfig.txt file, change to:
net.slp.answerBroadcast=false
Claude

acanas
Posts: 752
Joined: Tue Mar 17, 2009 5:52 pm

Re: Server disapear from the list of places

Post by acanas » Mon Apr 04, 2011 10:52 am

Let us know how it goes. Having the domain name not match the IP is likely to continue being a problem.

Post Reply