CmapTools on Ubuntu 9.04 - CmapTools Window empty

Having problems with IHMC CmapTools? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapTools, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
zrzavywa
Posts: 1
Joined: Mon Apr 27, 2009 11:14 am

CmapTools on Ubuntu 9.04 - CmapTools Window empty

Post by zrzavywa »

Hi

The CmapTools shows on my Ubuntu 9.04 only the CmapTools window frame without any symbols or content.

Any ideas what I could change to get CmapTools working?

Thanks

Walter
Attachments
Screenshot.png
marroyo
Posts: 65
Joined: Tue Mar 31, 2009 6:09 pm

Re: CmapTools on Ubuntu 9.04 - CmapTools Window empty

Post by marroyo »

Hi Walter,

Which version of CmapTools do you have installed?. We recommend that you install CmapTools v5.03 (http://cmap.ihmc.us/download/) , if you have any previous or beta version.

Please, verify if you have active "Desktop Efects" like COMPIZ or BERYL in your Linux configuration, theses programs causes that the graphics user interface of the Java applications not work properly.

Let me know if this fix your problem.

Mario Arroyo
cheekee
Posts: 1
Joined: Mon May 04, 2009 12:20 pm

Re: CmapTools on Ubuntu 9.04 - CmapTools Window empty

Post by cheekee »

Hi Mario,

I have exactly the same problem on Ubuntu 9.04 and am using the latest version 5.03 of Cmaptools. I have tried uninstalling and re-installing several times but it still doesn't work . The Views-Cmaptools applet works quite well, but the Cmap applet itself is just a single greyish colour. The styles applet doesn't seem to function in changing colours and only appears once. Once it is closed, it doesn't reappear no matter what I do. It doesn't matter whether I have another program running...I think tentatively, that the jre isn't working well on Ubuntu.

I have 3GB Ram and an Intel dual core T5800 system, that also dual-boots into either Windows Vista or Ubuntu...My Cmaptools works perfectly when I boot into Windows, but does not work on Ubuntu. For that matter it didn't work on my previous 8.10 version of Ubuntu either. I think all you have to do to test this out for yourself is to try and run the program yourself from an Ubuntu 9.04 machine.

Regards,
Cheekee ;)
rcarvajal
Posts: 80
Joined: Tue Mar 31, 2009 5:52 pm
Location: Pensacola, FL
Contact:

Re: CmapTools on Ubuntu 9.04 - CmapTools Window empty

Post by rcarvajal »

@cheekee:

It is not a problem of the JRE included with CmapTools, it is an incompatibility between Java and Compiz/Beryl.

Detailed information about CmapTools on Linux presents a blank (grey) cmap editor window can be found at the FAQ
Rodrigo Carvajal
Post Reply