Installation issue on Linux64: java.lang.IllegalArgumentException: Malformed \uxxxx encoding.

Having problems with IHMC CmapTools? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapTools, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
Posts: 1
Joined: Sun Oct 21, 2018 4:16 am

Installation issue on Linux64: java.lang.IllegalArgumentException: Malformed \uxxxx encoding.

Post by katomu » Sun Oct 21, 2018 4:38 am

I tried to install CmapTools on linux (kde neon based on Ubuntu 18.04 LTS) and I faced an issue that I was able to solve. Since I did not find that issue related to CmapTools (actually it is related to Java) I post the issue and my solution here:

I got the following error when calling the installer

Code: Select all

[09:25:04] user@hostname:~/Downloads$ ./Linux64CmapTools_v6.03_10-04-17.bin 
Preparing to install
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)

Stack Trace:
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
        at java.util.Properties.loadConvert(Unknown Source)
        at java.util.Properties.load0(Unknown Source)
        at java.util.Properties.load(Unknown Source)
        at Source)
        at com.zerog.lax.LAX.<init>(Unknown Source)
        at com.zerog.lax.LAX.main(Unknown Source)
In this error message the source of the error is unknown but I found a very similar message in the web ( where the source was identified as the PS1 variable.

So I changed my ~/.bashrc file. I changed

Code: Select all

export PS1='\[\033[1;31m\][\t] \[\033[0;36m\]\u\[\033[0m\]@\h:\w\$ '
which is generating the prompt:

Code: Select all

[hh:mm:ss] user@hostname:<currentFolder>$
(as you can see in my error message above)

Code: Select all

export PS1='\h:\w\$ '
which just gives

Code: Select all

I started a new terminal which now does not include the "@" in the prompt. I than ran the install once again in this new terminal and it worked as expected.

Site Admin
Posts: 686
Joined: Sat Dec 13, 2008 2:22 pm

Re: Installation issue on Linux64: java.lang.IllegalArgumentException: Malformed \uxxxx encoding.

Post by cmapadmin » Sun Oct 21, 2018 8:19 am

Thanks for the post.

Post Reply