Page 1 of 1

CmapTools in Linux

Posted: Sun Aug 09, 2020 4:05 pm
by worths1
Where does the CmapTools binary install in Linux. I'm trying to find it. I'm using Elementary OS and I installed from Terminal using the GUI.

BTW, there seems to be a forum bug. Every search returns the error "too many common words."

Re: CmapTools in Linux

Posted: Fri Aug 20, 2021 2:41 pm
by lostipod
I just installed this for my partner on Elementary OS 5 and had the same problem. I re-ran the installer, but this time chose her Home directory as the install path (the default location of

Code: Select all

/root/IHMC CmapTools
is bizarre and I could not find it just using

Code: Select all


Code: Select all

). After all that I realized that to launch the app, one has to launch from the terminal (from the install location chosen):

Code: Select all

The rights should be fine, even though the installer installs as user root and group root, everyone has execute permissions.

Now I just need to figure out how to create a link for her in the Dock, or I guess write a "script" with the command. No matter if I ran the installer bin in terminal mode or GUI mode, I got
Link Folder:

I'm assuming that's why the installer bin didn't create a nice shiny icon to click on to launch the application.

Re: CmapTools in Linux

Posted: Fri Aug 20, 2021 5:41 pm
by cmapadmin
That's correct -- on Linux, CmapTools is by default installed in your home folder, in the "IHMC CmapTools" subfolder. So if you are logged in as root, you will find it in /home/root/IHMC CmapTools (with root ownership since you installed it as root). If you installed it as a normal user, you can find it in /home/<userId>/IHMC CmapTools.

As mentioned, after changing to the installation folder, you can simply run the "./CmapTools" launch script from that folder.

You can manually add a shortcut icon to your desktop to launch CmapTools, but the details depend on your linux distribution and desktop environment. For elementary OS, this link may help: ... y-os-freya

- cmapadmin

Re: CmapTools in Linux

Posted: Mon Nov 22, 2021 2:33 pm
by lostipod
Ah, I see. I was installing it with sudo so by consequence it probably installed to root's home folder.

Re: CmapTools in Linux

Posted: Wed Apr 27, 2022 11:28 am
by tomcloyd
This is too complex. Needlessly so. I have been using Linux for years, and have also used CmapTools a lot, but not recently. Installing the Linux 64-bit download, I could NOT find the executable. Why not simply tell us how to launch the program after installing it? None of the "documentation" addresses this. This makes no sense to me whatsoever. Giving me roadmaps when I can't start the car is futile.

Re: CmapTools in Linux

Posted: Wed Apr 27, 2022 11:36 am
by cmapadmin
You are right. We have concentrated on making it easy for Windows and MacOS users but should take a look at the Linux installer. Most of the time Linux users figure things out by themselves but that is no excuse.

Re: CmapTools in Linux

Posted: Sun Jun 26, 2022 2:50 pm
by lostipod
Here it is, soon a year later and I'm reinstalling the OS (this time Fedora 36 GNOME) for my partner. I need to manually create the .desktop file. I'm wondering where the installer puts the icon for CmapTools. I can find some generic icon within GNOME I'm sure, but prefer to use the icon that the symlink "launcher" named CmapTools uses, if possible. I've looked in /home/username/IHMC CmapTools/ and can't find the CmapTools icon.

Some points of clarification from my post of about a year ago. Before I used a 3rd party .deb file because I didn't understand what to do with a .bin file, and for whatever reason didn't just follow the Linux installation instructions in the CmaptTools FAQ section here. This time I just followed the instructions with the 1st party install .bin file and it installed just fine, to the home directory as it should have without any drama, no issues with rights or anything. Just working on the launcher part now, as I don't want to tell my partner to launch CmapTools from the terminal. I could do a script that she could click on like before, but I want to up my game and to it properly with a .desktop file.

Re: CmapTools in Linux

Posted: Sun Jul 03, 2022 10:10 am
by lostipod
So as I mentioned I'm doing Fedora 36 with GNOME for my partner. According to this: ... ry.html.en

the icon cannot be a path:
"Specifies the filename of an icon that represents the item. Does not specify the path to the filename, or the file extension. "

Looking here: ... pps/3736/2
I installed gtk3-icon-browser to find a generic icon. Then I created a file called cmaptools.desktop under
with the following information:

[Desktop Entry]
Exec='/home/username/IHMC CmapTools/bin/CmapTools'

One may need to restart, I can't remember.

And it worked! I didn't get the default CmapTools icon, but much better than my hacky solution from last year.