I just lost my map :((((

Having problems with IHMC CmapTools? Think you have found a bug? Let us know!
Forum rules
Before you post a problem or bug, please be sure you have included the version number of IHMC CmapTools, the operating system and version, the amount of RAM, and any other information that allows us to be able to replicate the problem you are having. (i.e. what were you doing when the problem occur? were you running another program (application) by the time you have the problem?)
Post Reply
rgbrgb
Posts: 1
Joined: Thu Oct 08, 2020 10:56 pm

I just lost my map :((((

Post by rgbrgb »

Hello. Me and some friends were working on a map and suddenly it got corrupted.
We cannot open it anymore, we cannot export it, we cannot

When I try to open it online, it loads forever and nothing happen.
When I try to open using the software, I get a "unexpected client error".

We lost our work (it was quite big) :(

Is there a chance I could recover it?
What should I do? Where do I begin?

Thanks
cmapadmin
Site Admin
Posts: 728
Joined: Sat Dec 13, 2008 2:22 pm

Re: I just lost my map :((((

Post by cmapadmin »

If the Cmap was being stored in your own computer (My Cmaps) you will need to retrieve it from your backup. If it was in the Cmap Cloud or one of IHMC's CmapServers, we can retrieve it from our backup. As it is, the file is probably corrupted and can't be recovered. Can't tell what went wrong.
kalbun
Posts: 1
Joined: Fri Feb 05, 2021 12:52 pm

Re: I just lost my map :((((

Post by kalbun »

The same happened to me right now.
I suppose that the problem was related to a link that I added to a concept short before saving it.
1) created and saved a new CMap on the cloud
2) in the existing map (on the cloud), I added a link to the new map
3) link added, so far so good.
4) while saving the existing map, an error suddenly happened.

From then, I am unable to open the map. I also tried to do a copy in local but this didn't help.

The message I see is something like this: Error opening resource {0}

So frustrating... :-(
cmapadmin
Site Admin
Posts: 728
Joined: Sat Dec 13, 2008 2:22 pm

Re: I just lost my map :((((

Post by cmapadmin »

Please send us to cmapsupport@Ihmc.us your email address (account) and the name of the Cmap. We'll take al ook at it. If you worked on it for some time it could be the backup system has a copy. Right now the file seems to be corrupt because of the error.
cmapadmin
Site Admin
Posts: 728
Joined: Sat Dec 13, 2008 2:22 pm

Re: I just lost my map :((((

Post by cmapadmin »

If you were using the desktop version, please also send us all the logs. Their location is indicated at https://cmap.ihmc.us/docs/cmaptools-faqs#1-2
Post Reply